Imports a BCF file.
GSErrCode ACAPI_MarkUp_ImportFromBCF ( const IO::Location& fileLoc, const bool silentMode, const APIIFCRelationshipDataProc* ifcRelationshipDataProc, const void* par1, const bool openMarkUpPalette = false const bool alignBySurveyPoint = true );
Parameters
- fileLoc
- [in] The location of the BCF file.
- silentMode
- [in] Execute the import in silent mode, if its value is true then there will be no error or warning dialogs.
- ifcRelationshipDataProc
- [in] Optional user defined callback function which will supply API_IFCRelationshipData needed by BCF import when topics refers to element components like IFCBuildingElementParts. For more details see APIIFCRelationshipDataProc.
- par1
- [in] Optional parameter what will be passed for
ifcRelationshipDataProc
callback function.
- openMarkUpPalette
- [in] Open MarkUp Palette after import or not.
- alignBySurveyPoint
- [in] Align BCF views by Archicad Survey Point or Archicad Project Origin.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- The passed
fileLoc
is not a valid BCF file.
For other common API errors see the API Errors document.
Remarks
Use this function to import a BCF file.
This api command is already part of an Undoable session and should not be called inside of ACAPI_CallUndoableCommand.
Example
For detailed examples, please see the MarkUp_Manager add-on.GSErrCode GetIFCRelationshipData (GS::HashTable
* apiIfcRelationshipDataTable, const void* par1) {...} const CustomData* GetCustomData () {...} GSErrCode DoBCFImport () { GSErrCode err = NoError; const CustomData* data = GetCustomData (); DG::FileDialog openFileDLG (DG::FileDialog::Type::OpenFile); if (openFileDLG.Invoke ()) err = ACAPI_MarkUp_ImportFromBCF (openFileDLG.GetSelectedFile (), true, &GetIFCRelationshipData , data); return err; }
Requirements
- Version: API 23 or later
- Header: ACAPinc.h