ACAPI_​ModulData_​Delete

Removes the custom data section stored in the project database.

    GSErrCode  ACAPI_ModulData_Delete (
        const GS::UniString&     modulName = ""
    );

 

Parameters

modulName
[in] Identifier name of the modul data (optional).

 

Return Values

NoError
The information was returned successfully.
APIERR_NOMODULEDATA
No custom data section is saved into the project file identified by the add-on’s unique modul ID and the modulName parameter.

For other common errors see the list of error codes.

 

Remarks

This function is used to delete the custom data section embedded in the project database.

Calling ACAPI_ModulData_Delete is equivalent to ACAPI_ModulData_Store (nullptr).

This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.

 

Requirements

Version: API 13 or later
Header: ACAPinc.h

 

See Also

API_ModulData
ACAPI_ModulData_Store
ACAPI_ModulData_GetInfo
ACAPI_ModulData_Get
ACAPI_ModulData_GetList
ModulData Manager
API Functions