ACAPI_​ModulData_​GetInfo

Returns information on the custom data section stored in the project database.

    GSErrCode  ACAPI_ModulData_GetInfo (
        API_ModulData*           info,
        const GS::UniString&     modulName = ""
    );

 

Parameters

info
[out] The version and platform information of the stored moduldata.
modulName API 13 feature
[in] Identifier name of the modul data (optional).

 

Return Values

NoError
The information was returned successfully.
APIERR_BADPARS
The info parameter is nullptr.
APIERR_NOMODULEDATA
No custom data section is saved into the project file identified by the add-on’s unique modul ID and the modulName parameter.

For other common errors see the list of error codes.

 

Remarks

This function is used to retrieve version and platform information on the custom data section embedded in the project database, identified with the given modulName.

In order to get the stored data itself, use the ACAPI_ModulData_Get function.

 

Requirements

Version: API 4.1 or later
Header: ACAPinc.h

 

See Also

API_ModulData
ACAPI_ModulData_Get
ACAPI_ModulData_GetList
ACAPI_ModulData_Store
ModulData Manager
API Functions