ACAPI_​Navigator

Controls the Navigator of the server application.

    GSErrCode  ACAPI_Navigator (
        API_NavigatorID       code,
        void*                 par1 = nullptr,
        void*                 par2 = nullptr,
        void*                 par3 = nullptr
    );

 

Parameters

code
[in] Navigator function identifier.
par1
[in/out] The parameter depends on the code parameter.
par2
[in/out] The parameter depends on the code parameter.
par3
[in/out] The parameter depends on the code parameter.

 

Return Values

NoError
The Navigator function completed with success.
APIERR_BADID
Invalid code parameter was passed.

More return values can be found at the description of each Navigator function.

 

Remarks

This function is used to access the Navigator information of the server application.

The type of the Navigator function is specified with the code parameter.

API_NavigatorID

Description

 

 

Navigator management  4.3

 

APINavigator_GetNavigatorSetNumID

Returns the number of Navigator’s sets.

APINavigator_GetNavigatorSetID

Returns Navigator’s sets.

APINavigator_GetNavigatorItemID

Returns item of the Navigator.

APINavigator_GetNavigatorParentItemID

Returns parent item of the Navigator item.

APINavigator_GetNavigatorChildNumID

Returns children number of the Navigator item.

APINavigator_GetNavigatorChildrenItemsID

Returns children items of the Navigator item.

APINavigator_GetNavigatorViewID

Returns view of the Navigator item.

APINavigator_SearchNavigatorItemID

Returns views of of the requested database.

APINavigator_ChangeNavigatorViewID  Featuring API 10

Modifies a view in the Navigator.

APINavigator_NewNavigatorViewID  Featuring API 13

Creates a view in the Navigator.

APINavigator_DeleteNavigatorViewID  Featuring API 17

Deletes a view from the Navigator.

APINavigator_ChangeNavigatorItemID  Featuring API 18

Changes a Navigator view map item.

APINavigator_SetNavigatorItemPositionID  Featuring API 15

Moves Navigator item to an other place.

APINavigator_CloneProjectMapItemToViewMapID  Featuring API 24

Clones a Navigator item from the project map to view map.

 

 

Navigator viewpoint management  Featuring API 22

 

APINavigator_CreateNavigatorVPItemID

Creates a new viewpoint in the Navigator.

APINavigator_DeleteNavigatorVPItemID

Deletes an existing viewpoint from the Navigator.

APINavigator_ChangeNavigatorVPItemID

Changes an existing Navigator viewpoint.

APINavigator_GetNavigatorVPItemID

Gets the data of a given Navigator viewpoint.

APINavigator_GetNavigatorVPRootGroupsID

Gets the list of Navigator root groups.

APINavigator_GetNavigatorVPItemChildrenID

Gets the child items of a Navigator group.

APINavigator_RegisterCallbackInterfaceID

Registers an object that is called back by Archicad.

 

Requirements

Version: API 22 or later
Header: ACAPinc.h, APIdefs_Navigator.h

 

See Also

General Functions, API Functions