Sets notification handler for reservation changes of lockable objects.
GSErrCode ACAPI_Notify_CatchLockableReservationChange ( APILockChangeHandlerProc* handlerProc, const GS::HashSet<API_Guid>* filterLockablesInterestedOnly );
Parameters
- handlerProc
- [in] Notification handler function to be called on the specified event. Pass
nullptr
to unsubscribe from this notification. - filterLockablesInterestedOnly
- [in] List of guids of lockable objects; optional parameter for controlling the range of objects of interest. If passed, the lock change notifications will be sent for only these objects, otherwise every lock changes will be reported.
Return Values
NoError
- The function completed successfully.
For other common errors see the list of error codes.
Remarks
This function is used to subscribe an add-on to be notified when reservations of lockable objects (e.g. attributes, favorites, model view options) have been changed in Teamwork. Once a APILockChangeHandlerProc function pointer is passed, the add-on remains loaded in the memory, and receives the notifications. When the add-on does not need these notifications any more, you can stop receiving them by calling this function with nullptr
in the first argument.
In case the add-on is interested only in specified objects, you can set the focus on those objects by passing the list of the guids in the filterLockablesInterestedOnly
parameter (see the list of currently available lockable object sets). Note that there can be only one handler function set for this notification at the same time, that is you cannot set multiple handlers for different lists of lockable objects.
Example
See the Examples section of APILockChangeHandlerProc.
See also the Teamwork Control and Notification Manager example projects of the API Development Kit.
Requirements
- Version: API 15 or later
- Header: ACAPinc.h
See Also
APILockChangeHandlerProc
ACAPI_Notify_CatchElementReservationChange
Teamwork Control
Notification Manager
API Functions