ACAPI_​Notify_​GetParentElement

Returns the parent of the actual element your addon received notification for.

    GSErrCode  ACAPI_Notify_GetParentElement (
        API_Element*         element,
        API_ElementMemo*     memo,
        UInt64               mask,
        API_ElementUserData* userData
    );

 

Parameters

element
[out] The parent element to be retrieved.
memo
[out] Additional data of the parent element.
mask
[in] Mask for specifying the relevant memo handles to be retrieved.
userData
[out] Userdata of the parent element.

 

Return Values

NoError
The function was executed without error.
APIERR_REFUSEDCMD
There was no parent element during the action.

For other common API errors see the API Errors document.

 

Remarks

This function is used to retrieve the original element data from which the notified element has been derived. If you pass nullptr values in the memo and userData parameters, the function performs an ACAPI_Element_Get operation, otherwise it behaves like the ACAPI_Element_GetMemo or the ACAPI_Element_GetUserData function.

You can use this function to find out what changes have been made to the original element during the operation.

 

Example

See the example for ACAPI_Notify_CatchNewElement.

 

Requirements

Version: API 2.1 or later
Header: ACAPinc.h

 

See Also

API_Element
API_ElementMemo
API_ElementUserData
ACAPI_Notify_CatchNewElement
API_NotifyElementType
Notification Manager
API Functions