Unregister an event handler from your add-on.
GSErrCode ACAPI_Notify_UnregisterEventHandler ( const API_Guid& id );
Parameters
- id
- [in] The identifier of a previously registered event handler.
Return Values
NoError
- The requested operation finished successfully.
APIERR_BADPARS
- The requested operation failed due to an invalid
id
in-parameter.
For other common API errors see the API Errors document.
Remarks
If not specified otherwise by ACAPI_KeepInMemory the add-on will automatically unload if you unregister all event handlers.
Example
// ----------------------------------------------------------------------------- // Called when the Add-On is going to be unloaded // ----------------------------------------------------------------------------- GSErrCode __ACENV_CALL FreeData (void) { return ACAPI_Notify_UnregisterEventHandler (myEventHandlerId); }
Requirements
- Version: API 26 or later
- Header: ACAPinc.h