ACAPI_​Override_​ChangeOverrideCombination

Changes an override combination identified by its guid.

        GSErrCode  ACAPI_Override_ChangeOverrideCombination (
            const API_OverrideCombination&                combination,
            const GS::Array<API_Guid>* const              ruleList = nullptr
        );
    

 

Parameters

combination
[in] The combination to change.
ruleList
[in] The ids of the rules that the combination should “contain”, or nullptr if they shouldn’t be changed.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
The guid did not refer to a valid override combination or an element of the ruleList array did not refer to a valid override rule.
APIERR_BADNAME
The specified new name for the combination is invalid (empty, or whitespace only, or contains more than 255 characters)
APIERR_NAMEALREADYUSED
The specified new name for the combination is already taken in the current project.
APIERR_NOACCESSRIGHT
Tried to change a built-in combination.

For other common API errors see the API Errors document.

 

Example



GSErrCode MakeOverrideCombinationEmpty (API_OverrideCombination& combination)
{
    GS::Array<API_Guid> ruleList;
    return ACAPI_Override_ChangeOverrideCombination (combination, ruleList);
}

        
For more detailed examples, please see the Override_Test add-on.

 

Requirements

Version: API 20 or later
Header: ACAPinc.h

 

See Also

Visual Override,
API Functions