ACAPI_​Override_​ChangeOverrideRule

Changes an override rule identified by its guid.

        GSErrCode  ACAPI_Override_ChangeOverrideRule (
            const API_OverrideRule&     rule
        );
    

 

Parameters

rule
[in] The rule to change.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
The guid did not refer to a valid override rule.
APIERR_BADNAME
The specified new name for the rule is invalid (empty, or whitespace only, or contains more than 255 characters)
APIERR_NAMEALREADYUSED
The specified new name for the rule is already taken in the current project.
APIERR_NOACCESSRIGHT
Tried to change a built-in rule.

For other common API errors see the API Errors document.

 

Example



GSErrCode ChangeOverrideRuleName (const GS::UniString& newName, API_OverrideRule& rule)
{
    rule.name = newName;
    return ACAPI_Override_ChangeOverrideRule (rule);
}

        
For more detailed examples, please see the Override_Test add-on.

 

Requirements

Version: API 20 or later
Header: ACAPinc.h

 

See Also

Visual Override,
API Functions