ACAPI_​Override_​CreateOverrideCombination

Creates an override combination.

        GSErrCode  ACAPI_Override_CreateOverrideCombination (
            API_OverrideCombination&       combination,
            const GS::Array<API_Guid>&     ruleList
        );
    

 

Parameters

combination
[in] The combination to create.
[out] The guid of the newly created combination.
ruleList
[in] The ids of the rules that the combination should “contain”.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
The guid or name did not refer to a valid override combination.
APIERR_BADNAME
The specified name for the combination is invalid (empty, or whitespace only, or contains more than 255 characters)
APIERR_NAMEALREADYUSED
The specified name for the combination is already taken in the current project.

For other common API errors see the API Errors document.

 

Example



GSErrCode CreateEmptyOverrideCombination (const GS::UniString& name, API_OverrideCombination& combination)
{
    combination.name = name;
    GS::Array<API_Guid> ruleList;
    return ACAPI_Override_CreateOverrideCombination (combination, ruleList);
}

        
For more detailed examples, please see the Override_Test add-on.

 

Requirements

Version: API 20 or later
Header: ACAPinc.h

 

See Also

Visual Override,
API Functions