ACAPI_​Override_​CreateOverrideRule

Creates an override rule.

        GSErrCode  ACAPI_Override_CreateOverrideRule (
            API_OverrideRule&       rule
        );
    

 

Parameters

rule
[in] The rule to create.
[out] The guid of the newly created rule.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
The guid or name did not refer to a valid override rule.
APIERR_BADNAME
The specified name for the rule is invalid (empty, or whitespace only, or contains more than 255 characters)
APIERR_NAMEALREADYUSED
The specified name for the rule is already taken in the current project.

For other common API errors see the API Errors document.

 

Example



GSErrCode CreateEmptyOverrideRule (const GS::UniString& name, API_OverrideRule& rule)
{
    rule.name = name;
    rule.criterionXML = "";
    BNZeroMemory (rule.style, sizeof (rule.style));
    return ACAPI_Override_CreateOverrideRule (rule);
}

        
For more detailed examples, please see the Override_Test add-on.

 

Requirements

Version: API 20 or later
Header: ACAPinc.h

 

See Also

Visual Override,
API Functions