Retrieves a list of all override combinations in the current plan.
GSErrCode ACAPI_Override_GetOverrideCombinationList ( GS::Array<API_Guid>& combinationList );
Parameters
- combinationList
- [out] The list of all override combinations in the current plan.
Return Values
NoError
- The function has completed with success.
For other common API errors see the API Errors document.
Example
For more detailed examples, please see the Override_Test add-on.GSErrCode GetOverrideCombinationNames (GS::Array<GS::UniString>& combinationNames) { GS::Array<API_Guid> combinationsGuids; GSErrCode error = ACAPI_Override_GetOverrideCombinationList (combinationsGuids); if (error == NoError) { for (USize i = 0; i < combinationsGuids.GetSize(); ++i) { API_OverrideCombination combination = {combinationsGuids[i]}; error = ACAPI_Override_GetOverrideCombination (combination, nullptr); if (error == NoError) { combinationNames.Push (combination.name); } } } return error; }
Requirements
- Version: API 20 or later
- Header: ACAPinc.h