ACAPI_​Property_​ChangePropertyGroup

Changes an already existing property group in the current plan (identified by its guid).

    GSErrCode  ACAPI_Property_ChangePropertyGroup (
        const API_PropertyGroup&      group
    );

 

Parameters

group
[in] The property group to change.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
The guid of the parameter did not refer to a valid property group.
APIERR_BADPARS
The groupType of the parameter is not supported by the function.
APIERR_NOACCESSRIGHT
Do not have the right to modify a property group on a teamwork server.
APIERR_NAMEALREADYUSED
The new name of the group is already used.

For other common API errors see the API Errors document.

 

Example



GSErrCode RenameFirstPropertyGroup ()
{
    GS::Array<API_PropertyGroup> groups;
    GSErrCode error = ACAPI_Property_GetPropertyGroups (groups);
    if (error == NoError && groups.GetSize () > 0) {
       groups[0].name = "Renamed Property Group";
       groups[0].description = "Description is also modified";
       error = ACAPI_Property_ChangePropertyGroup (groups[0]);
    }

    return error;
}

For more detailed examples, please see the Property_Test add-on.

 

Requirements

Version: API 20 or later
Header: ACAPinc.h

 

See Also

Properties,
API Functions