ACAPI_​Property_​CreatePropertyGroup

Creates a property group in the current plan.

    GSErrCode  ACAPI_Property_CreatePropertyGroup (
        API_PropertyGroup&      group
    );

 

Parameters

group
[in] The property group to create.
[out] The guid field is overwritten with the id of the newly created property group.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
The groupType of the parameter is not supported by the function.
APIERR_NOACCESSRIGHT
Do not have the right to create a property group on a teamwork server.
APIERR_NAMEALREADYUSED
The name of the group is already used.

For other common API errors see the API Errors document.

 

Example



GSErrCode CreateExamplePropertyGroup (API_PropertyGroup& group)
{
    group.guid = APINULLGuid;
    group.name = "An example property group.";
    group.description = "This is an example property group.";

    return ACAPI_Property_CreatePropertyGroup (group);
}

For more detailed examples, please see the Property_Test add-on.

 

Requirements

Version: API 20 or later
Header: ACAPinc.h

 

See Also

Properties,
API Functions