Deletes a property definition in the current plan.
GSErrCode ACAPI_Property_DeletePropertyDefinition ( const API_Guid& propertyGuid );
Parameters
- propertyGuid
- [in] The identifier of the property definition to delete.
Return Values
NoError
- The function has completed with success.
APIERR_BADID
- The propertyGuid parameter did not refer to a valid property definition.
APIERR_NOACCESSRIGHT
- Do not have the right to delete a property definition on a teamwork server.
For other common API errors see the API Errors document.
Example
For more detailed examples, please see the Property_Test add-on.GSErrCode DeleteAllPropertyDefinitions () { GS::Array<API_PropertyDefinition> definitions; GSErrCode error = ACAPI_Property_GetPropertyDefinitions (APINULLGuid, definitions); for (UInt32 i = 0; error == NoError && i < definitions.GetSize (); i++) { error = ACAPI_Property_DeletePropertyDefinition (definitions[i].guid); } return error; }
Requirements
- Version: API 20 or later
- Header: ACAPinc.h