Retrieves one property definition identified by its guid.
GSErrCode ACAPI_Property_GetPropertyDefinition ( API_PropertyDefinition& definition );
Parameters
- definition
- [in] The guid field specifies the property definition to retrieve.
- [out] The retrieved property definition.
Return Values
NoError
- The function has completed with success.
APIERR_BADID
- The guid of the parameter did not refer to a valid property definition.
For other common API errors see the API Errors document.
Example
For more detailed examples, please see the Property_Test add-on.GSErrCode GetPropertyDefinitionName (const API_Guid& guid, GS::UniString& name) { API_PropertyDefinition definition; definition.guid = guid; GSErrCode error = ACAPI_Property_GetPropertyDefinition (definition); if (error == NoError) name = definition.name; return error; }
Requirements
- Version: API 20 or later
- Header: ACAPinc.h