ACAPI_​Property_​GetPropertyGroup

Retrieves one property group identified by its guid.

    GSErrCode  ACAPI_Property_GetPropertyGroup (
        API_PropertyGroup&      group
    );

 

Parameters

group
[in] The guid field specifies the property group to retrieve.
[out] The retrieved property group.

 

Return Values

NoError
The function has completed with success.
APIERR_BADID
The guid of the parameter did not refer to a valid property group.

For other common API errors see the API Errors document.

 

Example



GSErrCode GetPropertyGroupName (const API_Guid& guid, GS::UniString& name)
{
    API_PropertyGroup group;
    group.guid = guid;
    GSErrCode error = ACAPI_Property_GetPropertyGroup (group);
    
    if (error == NoError) 
        name = group.name;

    return error; 
}

For more detailed examples, please see the Property_Test add-on.

 

Requirements

Version: API 20 or later
Header: ACAPinc.h

 

See Also

Properties,
API Functions