ACAPI_​Property_​GetPropertyValueString

Convert an API property value to display string.

    GSErrCode ACAPI_Property_GetPropertyValueString (
        const API_Property&  apiProperty,
        GS::UniString*       resultString
    );

 

Parameters

apiProperty
[in] An evaluated property with its value.
resultString
[out] The string representation of the given property value. The function can resolve enumeration values (which are stored by the keyVariant in the apiProperty), as well as convert measured numeric values based on the current Project Preferences.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
Incorrect variant or param was specified.

For other common API errors see the API Errors document.

 

Remarks

This function was named APIAny_GetPropertyValueStringID in previous API versions.

 

Requirements

Version: API 25 or later
Header: ACAPinc.h

 

See Also

API Functions
ACAPI_Property_SetPropertyValueFromString
API_Property
Properties