Imports a property xml.
GSErrCode ACAPI_Property_Import ( const GS::UniString& propertyXml, API_PropertyDefinitionNameConflictResolutionPolicy conflictPolicy );
Parameters
- propertyXml
- [in] The property xml to import.
- conflictPolicy
- [in] Specifies how to resolve name conflicts.
Meaning
API_AppendConflictingProperties
Generate a new, unused name for the imported property
API_ReplaceConflictingProperties
Replace the definition in the plan with the imported one
API_SkipConflictingProperties
Keep the definition in the plan intact, and discard the imported one
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- Invalid property XML.
For other common API errors see the API Errors document.
Example
For detailed examples, please see the Property_Test add-on.
Requirements
- Version: API 21 or later
- Header: ACAPinc.h