ACAPI_​Protection_​GetProtectionMode

Retrieves information about the protection mode.

    UInt32 ACAPI_Protection_GetProtectionMode ();

 

Return Value

Bit field representing different states of the current protection environment.

 

Remarks

You can use the following predefined masks to retrieve information about the protection type.

  • APIPROT_SITE_MASK: More license (full version)
  • APIPROT_NFR_MASK: Not For Resale version (full version)
  • APIPROT_SCHOOL_MASK: School version (full version)
  • APIPROT_PPU_MASK: PPU version (full version)
  • APIPROT_NET_MASK: Network licensing
  • APIPROT_TW_MASK: TeamWork functionality is on
  • APIPROT_PROTEDU_MASK: Education version
  • APIPROT_START_MASK 11: Start edition

Usable masks in case of no hardware or software key:

  • APIPROT_EDU_MASK: Education version
  • APIPROT_DEMO_MASK: Demo version
  • APIPROT_TRIAL_MASK: Trial version
  • APIPROT_BTC_MASK 18: BIM Cloud Team Client version

This information can be used to restrict the functionality of your Add-On for certain Archicad editions and license types (use the bitwise-AND operator to find out your license parameters).

 

Example

bool IsInDemoMode ()
{
    return ACAPI_Protection_GetProtectionMode () & APIPROT_DEMO_MASK;
}
For more detailed examples, please see the Protection_Test add-on.

 

Requirements

Version: API 26 or later
Header: ACAPinc.h

 

See Also

API Functions