ACAPI_​Protection_​IsSSALevelAtLeast

Returns whether the SSA subscription passed in the parameter is available.

    bool ACAPI_Protection_IsSSALevelAtLeast (
        API_SSALevel      requiredLevel
    );

Parameters

requiredLevel
[in] The level to check the current level against.

 

Return Value

The function returns true if the current SSA-level is equal or greater than what’s passed in the parameter.

 

Example

bool ShouldEnableFeatureInAddOn ()
{
    return ACAPI_Protection_IsSSALevelAtLeast (API_SSALevels::Forward);
}
For more detailed examples, please see the Protection_Test add-on.

 

Requirements

Version: API 26 or later
Header: ACAPinc.h

 

See Also

API Functions