ACAPI_​Register_​AddOnObjectHandler

Registers the add-on to be called for merging and converting its custom data stored in AddOnObjects.

    GSErrCode  ACAPI_Register_AddOnObjectHandler (
        void
    );

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

Call this function from RegisterInterface to let Archicad know that the add-on has APIAddOnObjectMergeHandlerProc and/or APIAddOnObjectSaveOldFormatHandlerProc and/or APIAddOnObjectConvertNewFormatHandlerProc callback function implemented for merging and converting its custom data. In order this functions to be called on the adequate event, the add-on needs to pass the function pointers to Archicad from Initialize with ACAPI_Install_AddOnObjectMergeHandler, ACAPI_Install_AddOnObjectSaveOldFormatHandler and ACAPI_Install_AddOnObjectConvertNewFormatHandler, respectively.

 

Requirements

Version: API 19 or later
Header: ACAPinc.h

 

See Also

APIAddOnObjectSaveOldFormatHandlerProc
APIAddOnObjectConvertNewFormatHandlerProc
APIAddOnObjectMergeHandlerProc
AddOnObject Manager
API Functions