Registers an attribute manager format which can be used in attribute manager import.
GSErrCode ACAPI_Register_AttributeImportFormat ( const API_AttributeManagerFormat& formatData );
Parameters
- formatData
- [in] Stores parameters of the new attribute manager import format.
Return Values
NoError
- The function has completed with success.
For other common API errors see the API Errors document.
Remarks
For further informations read the documentation of API_AttributeManagerFormat structure.
Example
//------------------------------------------------------ // Interface definitions //------------------------------------------------------ GSErrCode __ACDLL_CALL RegisterInterface (void) { API_AttributeManagerFormat formatData = {}; formatData.fileCreator = 'GSAC'; formatData.fileType = 'TEXT'; formatData.fileExtension = "txt"; formatData.popupText = "Test txt file"; return ACAPI_Register_AttributeImportFormat (formatData); }
Requirements
- Version: API 26 or later
- Header: ACAPinc.h