ACAPI_​Register_​AttributePanel

Appends a custom panel to an attribute settings dialog.

    GSErrCode  ACAPI_Register_AttributePanel (
        Int32              refCon,
        API_AttrTypeID     attr,
        short              iconId,
        short              stringId,
        short              pageId,
        short              growType
    );

 

Parameters

refCon
[in] Unique reference number chosen for this panel
attr
[in] The attribute type that identifies the settings dialog
iconId
[in] Panel icon resource ID
stringId
[in] Title text to appear in the handler area of the panel
pageId
[in] Dialog resource ID of the tabpage
growType API 12
[in] Grow type of the tab page: can be DG_DLG_NOGROW, DG_DLG_HGROW, DG_DLG_VGROW, or DG_DLG_HGROW | DG_DLG_VGROW. This parameter is optional, the default is DG_DLG_NOGROW.

 

Return Values

APIERR_BADPARS
The attr parameter is invalid.
APIERR_NOTSUPPORTED
The attribute type does not support custom panels.
NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

This function appends a new panel into an attribute settings dialog.

For more details refer to the general description of Custom Panels in Settings Dialogs.

 

Requirements

Version: API 4.1 or later
Header: ACAPinc.h

 

See Also

API_AttrTypeID
ACAPI_Install_PanelHandler
ACAPI_Register_SettingsPanel
ACAPI_Register_InfoBoxPanel
Custom Panels in Settings Dialogs
API Functions