Registers built-in library parts to be loaded.
GSErrCode ACAPI_Register_BuiltInLibrary ( void );
Return Values
NoError
- The function has completed with success.
For other common API errors see the API Errors document.
Remarks
This function notifies the host application that your add-on has library parts compiled into the add-on as ‘FILE’ resources.
The application will add the add-on module to the active libraries and the library parts will be available as read only objects.
You can retrieve the unique ID of a built-in library part with the APIAny_GetBuiltInLibpartUnIdID goodie function.
Example
The StairMaker add-on has its own subtype template library part derived from the General Stair subtype.
In order to compile the library part into the add-on module, the library part should be copied among the localized resource files of the add-on, and there must be a reference to it in the .GRC file:
'FILE' 132 "StairMaker Stair.gsm" { "StairMaker Stair.gsm" }
Registration in the RegisterInterface
function:
//------------------------------------------------------ // Interface definitions //------------------------------------------------------ GSErrCode __ACENV_CALL RegisterInterface (void) { ACAPI_Register_BuiltInLibrary (); return NoError; } // RegisterInterface
Requirements
- Version: API 4.1 or later
- Header: ACAPinc.h
See Also
Library Part Overview
Library Part Manager
APIAny_GetBuiltInLibpartUnIdID
API Functions