ACAPI_​Register_​ESYM

Registers an external symbol type with Archicad.

    GSErrCode  ACAPI_Register_ESYM (
        GSType            signature,
        API_LibTypeID     typeID,
        short             stringResID
    );

 

Parameters

signature
[in] Unique identifier of the new symbol type (a four-character ID).
typeID
[in] Type of the new symbol (can be API_ObjectID, API_LampID, API_WindowID, or API_DoorID).
stringResID
[in] Resource containing the description of the new symbol type.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
Invalid symbol type.

For other common API errors see the API Errors document.

 

Remarks

This function should be called from your add-on’s RegisterInterface routine. More than one external symbol can be registered from one add-on. After registration you should also install a callback function with ACAPI_Install_ESYMHandler in your Initialize function, which will handle the events coming from Archicad.

 

Example


//------------------------------------------------------
// Interface definitions
//------------------------------------------------------
GSErrCode __ACENV_CALL  RegisterInterface (void)
{
    GSErrCode   err;

    // Register ESYM
    err = ACAPI_Register_ESYM ('GRPH', API_LampID, 32611);

    return err;
}               /* RegisterInterface */

 

Requirements

Version: API 4.1 or later
Header: ACAPinc.h

 

See Also

ACAPI_Install_ESYMHandler,
API Functions