ACAPI_​Register_​InfoBoxPanel

Appends a custom panel to the info box.

    GSErrCode  ACAPI_Register_InfoBoxPanel (
        Int32                   refCon,
        const API_ElemType&     tool,
        short                   stringId,
        short                   pageId,
        bool                    visibleByDefault
    );

 

Parameters

refCon
[in] Unique reference number chosen for this panel
tool
[in] The element type that identifies the settings dialog
stringId
[in] Title text to appear in the handler area of the panel
pageId
[in] Dialog resource ID of the tabpage
visibleByDefault API 11
[in] Show or hide the panel by default (optional parameter, false if omitted)

 

Return Values

APIERR_BADPARS
The passed element type is invalid.
APIERR_BADID
The passed tool / variation parameter pair does not identify a valid toolbox item (including invisible tools).
NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

This function appends a new panel into an element settings dialog specified by tool. In order to get panel create/destroy events you must install the panel handler callback functions with ACAPI_Install_PanelHandler.

Compared to the ACAPI_Register_SettingsPanel function there is no need to specify icon resource ID.

For more details refer to the general description of Custom Panels in Settings Dialogs.

 

Requirements

Version: API 4.1 or later
Header: ACAPinc.h

 

See Also

API_ElemType
ACAPI_Install_PanelHandler
Custom Panels in Settings Dialogs
ACAPI_Register_SettingsPanel
ACAPI_Register_AttributePanel
API Functions