Registers the add-on to be called for merging and converting its moduldata.
GSErrCode ACAPI_Register_ModulDataHandler ( void );
Return Values
NoError
- The function has completed with success.
For other common API errors see the API Errors document.
Remarks
Call this function from RegisterInterface to let Archicad know that the add-on has APIModulDataMergeHandlerProc and/or APIModulDataSaveOldFormatHandlerProc callback function implemented for merging and converting its modules. In order this functions to be called on the adequate event, the add-on needs to pass the function pointers to Archicad from Initialize with ACAPI_Install_ModulDataMergeHandler and ACAPI_Install_ModulDataSaveOldFormatHandler, respectively.
Requirements
- Version: API 13 or later
- Header: ACAPinc.h
See Also
API_ModulData
ACAPI_ModulData_GetInfo
ACAPI_ModulData_Get
ACAPI_ModulData_GetList
ACAPI_ModulData_Delete
APIModulDataSaveOldFormatHandlerProc
APIModulDataMergeHandlerProc
ModulData Manager
API Functions