Registers a property handler.
GSErrCode ACAPI_Register_PropertyObjectHandler ( short assignStrResID );
Parameters
- assignStrResID
- [in] The string resource ID, which will be used in Archicad’s dialogs.
Return Values
NoError
- The function has completed with success.
For other common API errors see the API Errors document.
Remarks
This function should be called from the RegisterInterface routine in your add-on.
Example
//------------------------------------------------------ // Interface definitions //------------------------------------------------------ GSErrCode __ACENV_CALL RegisterInterface (void) { ACAPI_Register_Menu (MenuResId, MenuTextResId, MenuCode_Calculate, MenuFlag_Default); ACAPI_Register_PropertyObjectHandler (PropertyResId); return NoError; } // RegisterInterface
Requirements
- Version: API 4.1 or later
- Header: ACAPinc.h
See Also
ACAPI_Install_PropertyObjectHandler,
RegisterInterface, API Functions