ACAPI_​Register_​PropertyVisibilityHandler

Tells Archicad that your add-on wants to modify property visibility.

    GSErrCode  ACAPI_Register_PropertyVisibilityHandler ();

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

This function should be called from the RegisterInterface routine in your add-on.

 

Example


//------------------------------------------------------
// Interface definitions
//------------------------------------------------------
GSErrCode __ACENV_CALL  RegisterInterface (void)
{
    GSErrCode err = ACAPI_Register_Menu (32500, 32600, MenuCode_UserDef, MenuFlag_Default);
    if (err != NoError) {
        return err;
    }

    err = ACAPI_Register_PropertyVisibilityHandler ();
    if (err != NoError) {
        return err;
    }
    
    return NoError;
}   // RegisterInterface

 

Requirements

Version: API 21 or later
Header: ACAPinc.h

 

See Also

Classification and Property Visibility,
RegisterInterface, API Functions