ACAPI_​Register_​PublishFormat

Registers a publish format which can be used in publisher tree.

    GSErrCode  ACAPI_Register_PublishFormat (
        API_PublishFormatData     formatData,
    );

 

Parameters

formatData
[in] Stores parameters of the new publish format

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

For further informations read the documentation of API_PublishFormatData structure.

 

Example


//------------------------------------------------------
// Interface definitions
//------------------------------------------------------
GSErrCode	__ACDLL_CALL	RegisterInterface (void)
{
    API_PublishFormatData formatData = {};
    formatData.mimeType = "text/Testxml";
    formatData.popUpText = "TestXML";
    formatData.fileExtText2D = "testFormat";
    formatData.fileExtText3D = "testFormat3d";
    formatData.windowTypes = { APIWind_AllID };
    formatData.singleFile = false;
    formatData.iconID = DG::Icon::NoIcon;
    
    return ACAPI_Register_PublishFormat (formatData);
}

 

Requirements

Version: API 23 or later
Header: ACAPinc.h

 

See Also

RegisterInterface,
API_PublishFormatData,
API Functions