ACAPI_​Register_​RequiredService

Check the availability of an other add-on’s command.

    GSErrCode  ACAPI_Register_RequiredService (
        const API_ModulID*     modulID,
        GSType                 cmdID,
        Int32                  cmdVersion
    );

 

Parameters

modulID
[in] The modul ID of the add-on containing the required service.
cmdID
[in] The command identifier of the required service.
cmdVersion
[in] The command version of the required service.

 

Return Values

NoError
The function has completed with success.
APIERR_GENERAL
The command isn’t supported service.

For other common API errors see the API Errors document.

 

Remarks

This function checks for the availability of an other add-on’s command, without which it cannot run. The other add-on should provide all the necessary information. The function should be called from the RegisterInterface function of the add-on.

 

Example


//------------------------------------------------------
// Interface definitions
//------------------------------------------------------
GSErrCode __ACENV_CALL  RegisterInterface (void)

{
    GSErrCode   err;

    //
    // Register command services
    //
    err = ACAPI_Register_RequiredService ('DWFO', 4L);

    return err;
}               // RegisterInterface

 

Requirements

Version: API 4.1 or later
Header: ACAPinc.h

 

See Also

RegisterInterface, ACAPI_Register_SupportedService,
API Functions