ACAPI_​Register_​SettingsObserver

Create an observer to an element settings dialog.

    GSErrCode  ACAPI_Register_SettingsObserver (
        const API_ElemType&  tool,
    );

 

Parameters

tool
[in] The element type that identifies the settings dialog

 

Return Values

APIERR_BADPARS
The passed element type is invalid.
APIERR_BADID
The passed tool does not identify a valid toolbox item (including invisible tools).
NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

This function creates an observer for an element settings dialog specified by tool. In order to get settings dialog create\destroy events you must install the settings handler callback functions with ACAPI_Install_SettingsHandler.

This function should be called from your add-on’s RegisterInterface routine. You can register more than one observers from the same add-on for different settings dialogs.

New in API 26 From version 26 the tool and variation parameters were merged into a single API_ElemType parameter.

 

Example

Refer to the Panel_Test example project of the API Development Kit.

 

Requirements

Version: API 20 or later
Header: ACAPinc.h

 

See Also

API_ElemType
API Functions