Registers a command which can be used by other add-ons.
GSErrCode ACAPI_Register_SupportedService ( GSType cmdID, Int32 cmdVersion );
Parameters
- cmdID
- [in] The command identifier of the supported service.
- cmdVersion
- [in] The command version of the supported service.
Return Values
NoError
- The function has completed with success.
For other common API errors see the API Errors document.
Remarks
The function registers one of your add-on’s command, and makes it avaliable for other add-ons. This should be called from the RegisterInterface function of the add-on.
Example
//------------------------------------------------------ // Interface definitions //------------------------------------------------------ GSErrCode __ACENV_CALL RegisterInterface (void) { GSErrCode err; // // Register command services // err = ACAPI_Register_SupportedService ('DWFO', 4L); return err; } // RegisterInterface
Requirements
- Version: API 4.1 or later
- Header: ACAPinc.h
See Also
RegisterInterface, ACAPI_Register_RequiredService,
API Functions