Changes the current marquee selection.
GSErrCode ACAPI_Selection_SetMarquee ( API_SelectionInfo* selectionInfo );
Parameters
- selectionInfo
- [in] The parameters of the marquee to be set.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- The
selectionInfo
parameter isnullptr
APIERR_BADDATABASE
- The active database is neither the floorplan, nor a section database
For other common API errors see the API Errors document.
Remarks
This function is used to change the marquee on a floorplan or section window. The typeID
field of the selectionInfo
must be API_MarqueePoly
, API_MarqueeHorBox
or API_MarqueeRotBox
in order to set a new marquee outline, otherwise the actual marquee will be removed.
The function has no effect on the individual selection of elements.
In case of API_MarqueePoly
type marquee do not forget to release the coordinate handle passed in the selectionInfo
parameter.
Requirements
- Version: API 3.1 or later
- Header: ACAPinc.h
See Also
API_SelectionInfo,
ACAPI_Element_Select,
Selection Manager, API Functions