ACAPI_​SetPreferences

Saves custom preferences data into the preferences file.

    GSErrCode  ACAPI_SetPreferences (
        Int32           version,
        GSSize          nByte,
        const void*     data
    );

 

Parameters

version
[in] The version of the data to be stored.
nByte
[in] The size of the data to be stored.
data
[in] The preferences data you would like to store.

 

Remarks

This function is used to save your own options or preferences into the preferences file of the server application, and can be later retrieved with ACAPI_GetPreferences.

6.1  If you store incompatible versions of preferences data in different Archicad releases, use the ACAPI_SetPreferences_OldVersion function to define preferences to be saved into the older project file formats.

 

Requirements

Version: API 4.1 or later
Header: ACAPinc.h

 

See Also

Saving Add-On data into the Preferences and the Project File
ACAPI_GetPreferences
ACAPI_GetPreferences_Platform
ACAPI_SetPreferences_OldVersion
API Functions