ACAPI_​TeamworkControl_​FindLockableObjectSet

Retrieves the unique identifier of a lockable object set with a string identifier.

    API_Guid  ACAPI_TeamworkControl_FindLockableObjectSet (
        const GS::UniString&     objectSetName
    );

 

Parameters

objectSetName
[in] String identifier of the lockable object set (see below)

 

Return Values

The function returns the Guid of the named lockable object set if found by the given objectSetName string, otherwise it returns APINULLGuid.

 

Remarks

This function is used to retrieve the identifier of a named lockable object set, such as attribute types, favorites, model view options.

In certain cases lockable object sets need to be reserved simultaneously. For this purpose compound lockable object sets were introduced, to hold the lockable object sets, and to make these sets be reserved together. Reserving individually a lockable object set which belongs to a compound one may result insecure functionality in the Teamwork project, should be avoided.

Compound lockable object sets are indentified with a string. Currently the following compound lockable object sets are used:

  • Layers, Layer Combinations (compound identifier name: "LayerSettingsDialog")
  • Project Preferences Data, Dimension Standards (compound identifier name: "PreferencesDialog")

API 20 Note that before API version 20, this function handled compound lockable object sets only. From API 20 you need to use this function to retrieve the guid of all lockable object sets.

The list of the currently available lockable object set identifiers:

Object set Identifier string
Building Materials Featuring API 17 "BuildingMaterials"
Cities "Cities"
Composites "Composites"
Favorites "Favorites"
Fill Types "FillTypes"
Layers, Layer Combinations "LayerSettingsDialog"
Library Manager "ProjectLibraryList"
Line Types "LineTypes"
Markup Styles "MarkupStyles"
MEP Systems "MEPSystems"
Model View Options "ModelViewOptions"
Operation Profiles Featuring API 16 "OperationProfiles"
Pen Tables "PenTables"
Profiles "Profiles"
Project Info "ProjectInfo"
Project Location API 25 feature "GeoLocation"
Project Preferences, Dimension Standards "PreferencesDialog"
Renovation Override Styles Featuring API 15 "GraphicOverrides"
Surface Materials "Surfaces"
Zone Categories "ZoneCategories"

For more information on lockable object sets see the Teamwork Control page.

 

Example

See the Example section of ACAPI_TeamworkControl_ReleaseLockable.

 

Requirements

Version: API 13 or later
Header: ACAPinc.h

 

See Also

ACAPI_TeamworkControl_HasCreateRight
ACAPI_TeamworkControl_HasDeleteModifyRight
ACAPI_TeamworkControl_GetLockableStatus
ACAPI_TeamworkControl_ReserveLockable
ACAPI_TeamworkControl_ReleaseLockable
Teamwork Control
API Functions