ACAPI_​TeamworkControl_​GetTeamworkProjectDetails

Extracts details from the given location about the teamwork project.

    GSErrCode  ACAPI_TeamworkControl_GetTeamworkProjectDetails (
        const IO::Location&     twProjectLocation,
        GS::UniString*          serverUrl = nullptr,
        GS::UniString*          projectName = nullptr,
        GS::UniString*          userName = nullptr
    );

 

Parameters

twProjectLocation
[in] The location URI of the teamwork project.
serverUrl
[out] The URL of the teamwork (BIMcloud) server.
projectName
[out] The name of the project on the server.
userName
[out] The username of the logged in user.

 

Return Values

NoError
The function has completed with success.
APIERR_NOTEAMWORKPROJECT
The given project is not Teamwork project.

For other common errors see the list of error codes.

 

Remarks

This function extracts information only from the given location. It does not try to reach the server and does not retrieve any data from it.

 

Example

GS::UniString   serverUrl;
GS::UniString   projectName;
GS::UniString   userName;
GSErrCode err = ACAPI_TeamworkControl_GetTeamworkProjectDetails (twProjectLocation,
                                                                 &serverUrl,
                                                                 &projectName,
                                                                 &userName);

if (err != NoError) {
    ACAPI_WriteReport ("The given location does not refer to a teamwork project.", true);
}

 

Requirements

Version: API 25
Header: ACAPinc.h

 

See Also

Teamwork Control
API Functions