ACAPI_​TeamworkControl_​GetUsernameFromId

Retrieves the username of a user identified by a short id in a Teamwork project.

    GSErrCode  ACAPI_TeamworkControl_GetUsernameFromId (
        short              userId,
        GS::UniString*     username
    );

 

Parameters

userId
[in] Unique identifier of the user
username
[out] The name of the user

 

Return Values

NoError
The function has completed with success.
APIERR_NOPLAN
There is no open project.
APIERR_NOTEAMWORKPROJECT
The current project is not Teamwork project.

 

Requirements

Version: API 25 or later
Header: ACAPinc.h

 

Example

The Teamwork_Control example project of the DevKit shows samples how to use this function.

 

See Also

ACAPI_TeamworkControl_IsOnline
ACAPI_TeamworkControl_GetUsernameFromId
ACAPI_TeamworkControl_GetLockableStatus
ACAPI_TeamworkControl_ReserveLockable
ACAPI_TeamworkControl_ReserveElements
ACAPI_TeamworkControl_GetHotlinkCacheManagementOwner
Teamwork Control
API Functions