ACAPI_​TeamworkControl_​HasConnection

Tells whether the currently opened project is a Teamwork project.

    bool  ACAPI_TeamworkControl_HasConnection (
        void
    );

 

Return Values

true
The current project is a shared Teamwork project.
false
The current project is a solo project, or there is no open project at all.

 

Remarks

This function tells if the currently project was opened in Teamwork mode, that is the user is joined to a shared Teamwork project on a BIM Server.

Note that being connected to a Teamwork project does not mean necessarily online connection to the server. In order to check the online-offline status, use ACAPI_TeamworkControl_IsOnline.

 

Example


if (!ACAPI_TeamworkControl_HasConnection ())
    ACAPI_WriteReport ("This function is available only in Teamwork mode", true);

 

Requirements

Version: API 13 or later
Header: ACAPinc.h

 

See Also

ACAPI_TeamworkControl_IsOnline
Teamwork Control
API Functions