Checks whether the current Teamwork user has access right to create a certain type of object.
bool ACAPI_TeamworkControl_HasCreateRight ( const API_Guid& objectId );
Parameters
- objectId
- [in] Unique identifier of the object
Return Values
true
- The current user has sufficient privileges to create the given type of objects.
false
- The current user is not allowed to create the given type of objects.
Remarks
Use this function to decide whether the current Teamwork user has right to create a given type of objects. The access rights are pre-set by the Project Administrator.
Example
API_Guid objectSetGuid = ACAPI_TeamworkControl_FindLockableObjectSet ("LineTypes"); if (!ACAPI_TeamworkControl_HasCreateRight (objectSetGuid)) ACAPI_WriteReport ("You have insufficient privileges to create Line Type attributes", true);
Requirements
- Version: API 13 or later
- Header: ACAPinc.h
See Also
ACAPI_TeamworkControl_HasDeleteModifyRight
Teamwork Control
API Functions