ACAPI_​TeamworkControl_​HasDeleteModifyRight

Checks whether the current Teamwork user has access right to delete or modify a certain type of object.

    bool  ACAPI_TeamworkControl_HasDeleteModifyRight (
        const API_Guid&     objectId
    );

 

Parameters

objectId
[in] Unique identifier of the object

 

Return Values

true
The current user has sufficient privileges to delete or modify the given type of objects.
false
The current user is not allowed to delete or modify the given type of objects.

For other common errors see the list of error codes.

 

Remarks

Use this function to decide whether the current Teamwork user has right to delete or modify a given type of objects. The access rights are pre-set by the Project Administrator.

 

Example


API_Guid objectSetGuid = ACAPI_TeamworkControl_FindLockableObjectSet ("FillTypes");
if (!ACAPI_TeamworkControl_HasDeleteModifyRight (objectSetGuid))
    ACAPI_WriteReport ("You have insufficient privileges to modify/delete Fill Type attributes", true);

 

Requirements

Version: API 13 or later
Header: ACAPinc.h

 

See Also

ACAPI_TeamworkControl_HasCreateRight
Teamwork Control
API Functions