Tells whether the client is online connected to the BIM server.
bool ACAPI_TeamworkControl_IsOnline ( void );
Return Values
true
- The Teamwork user is working in online mode.
false
- The Teamwork user is working in offline mode.
Remarks
Use this function to check if the connection status between the client application and the BIM server is online.
Note that a Teamwork user joined to a shared project is still in Teamwork mode even if the connection staus is offline. To check whether the project the user is working with is a Teamwork project, use ACAPI_TeamworkControl_HasConnection.
Example
if (!ACAPI_TeamworkControl_IsOnline ()) { ACAPI_WriteReport ("Sorry, the BIM Server is currently not available", true);
Requirements
- Version: API 13 or later
- Header: ACAPinc.h
See Also
ACAPI_TeamworkControl_HasConnection
Teamwork Control
API Functions