Releases elements in Teamwork mode.
GSErrCode ACAPI_TeamworkControl_ReleaseElements ( const GS::PagedArray<API_Guid>& elements, bool enableDialogs = true );
Parameters
- elements
- [in] List of elements to be released.
- enableDialogs
- [in] Show dialogs during the process? (optional, by default the dialogs are enabled)
Return Values
NoError
- The function has completed with success.
APIERR_NOPLAN
- There is no open project.
APIERR_NOTEAMWORKPROJECT
- The current project is not Teamwork project.
For other common errors see the list of error codes.
Remarks
This function is used to release the elements specified with the guid list.
This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.
Example
GS::PagedArray<API_Guid> elements; elements.Push (elementToRelease.header.guid); ACAPI_TeamworkControl_ReleaseElements (elements);
Requirements
- Version: API 13 or later
- Header: ACAPinc.h
See Also
ACAPI_TeamworkControl_ReserveElements
ACAPI_Notify_CatchElementReservationChange
Teamwork Control
API Functions