ACAPI_​TeamworkControl_​ReleaseHotlinkCacheManagement

Releases the Hotlink/XRef Management in Teamwork mode.

    GSErrCode  ACAPI_TeamworkControl_ReleaseHotlinkCacheManagement (
        void
    );

 

Return Values

NoError
The function has completed with success.
Error
The Hotlink/XRef Management is reserved by another team member.
APIERR_NOPLAN
There is no open project.
APIERR_NOTEAMWORKPROJECT
The current project is not a Teamwork project.

For other common errors see the list of error codes.

 

Remarks

This function is used to release the Hotlink/XRef Management.

This function performs complete operations, so it cannot be called neither during undoable operations nor during non-undoable commands. See more details on this topic at Command Overview.

 

Example


GSErrCode err = ACAPI_TeamworkControl_ReleaseHotlinkCacheManagement ();
if (err != NoError) {
    ACAPI_WriteReport ("The Hotlink/XRef Management has been successfully released.", true);
}

 

Requirements

Version: API 18 or later
Header: ACAPinc.h

 

See Also

ACAPI_TeamworkControl_ReserveHotlinkCacheManagement
ACAPI_TeamworkControl_GetHotlinkCacheManagementOwner
Teamwork Control
API Functions