AddPolyNodeProc

Callback function for custom feedback while editing polygons.

    typedef void  AddPolyNodeProc (
        const API_Coord3D*     c
    );

 

Parameters

c
[out] Actual mouse coordinate.

 

Remarks

You should implement this function if you have to give graphical feedback for the input operation invoked from your API tool add-on. This callback routine should be passed as a parameter when calling the APIIo_GetPolyID interface function. During the input process your procedure is called when the user adds a new node to the polygon. In the c parameter you get the coordinate of the node.

 

Requirements

Version: API 3.1 or later
Header: APIdefs_Callback.h

 

See Also

API_RubberPolyCallbacks, API_Coord3D,
RubberLineInfoProc, DelPolyNodeProc, APIIo_GetPolyID,
ACAPI_Interface, API Functions