API Functions

ACAPI_3D_CreateSight
ACAPI_3D_DecomposePgon
ACAPI_3D_DeleteSight
ACAPI_3D_GetComponent
ACAPI_3D_GetCurrentWindowSight
ACAPI_3D_GetCutPolygonInfo  API 18 feature
ACAPI_3D_GetNum
ACAPI_3D_SelectSight
 
ACAPI_ActionCenter_Check API 25 feature
 
ACAPI_ActivatePropertyObjectHandler
 
ACAPI_AddOnObject_CreateObject
ACAPI_AddOnObject_CreateClientOnlyObject  API 21 feature
ACAPI_AddOnObject_CreateUniqueObject  API 21 feature
ACAPI_AddOnObject_CreateUniqueObjectMore  API 21 feature
ACAPI_AddOnObject_DeleteObject
ACAPI_AddOnObject_ExistsObject
ACAPI_AddOnObject_GetObjectContent
ACAPI_AddOnObject_GetObjectGuidFromName
ACAPI_AddOnObject_GetClientOnlyObjectGuidFromName  API 21 feature
ACAPI_AddOnObject_GetUniqueObjectGuidFromName  API 21 feature
ACAPI_AddOnObject_GetObjectList
ACAPI_AddOnObject_GetTeamworkOwnerId
ACAPI_AddOnObject_GrantObjects
ACAPI_AddOnObject_ModifyObject
ACAPI_AddOnObject_ReleaseObjects
ACAPI_AddOnObject_RequestObjects
ACAPI_AddOnObject_ReserveObjects
ACAPI_AddOnObject_SetUIProperties
 
ACAPI_AnalyticalModel_AddLoadCaseToLoadCombination  API 25 feature
ACAPI_AnalyticalModel_ConvertAnalyticalLinkToNonShortest  API 24 feature
ACAPI_AnalyticalModel_CreateAnalyticalLoadCase  API 25 feature
ACAPI_AnalyticalModel_CreateAnalyticalLoadCombination  API 25 feature
ACAPI_AnalyticalModel_CreateAnalyticalLoadGroup  API 25 feature
ACAPI_AnalyticalModel_CreateElementFromCurveMember  API 24 feature
ACAPI_AnalyticalModel_CreateElementFromSegmentedSurfaceMember  API 24 feature
ACAPI_AnalyticalModel_CreateElementFromSurfaceMember  API 24 feature
ACAPI_AnalyticalModel_DeleteAnalyticalLoadCase  API 25 feature
ACAPI_AnalyticalModel_DeleteAnalyticalLoadCombination  API 25 feature
ACAPI_AnalyticalModel_DeleteAnalyticalLoadGroup  API 25 feature
ACAPI_AnalyticalModel_GetAllAnalyticalLoadCases  API 25 feature
ACAPI_AnalyticalModel_GetAnalyticalEdgeLoadGeometry  API 25 feature
ACAPI_AnalyticalModel_GetAnalyticalLinkGeometry  API 24 feature
ACAPI_AnalyticalModel_GetAnalyticalLoadCase  API 25 feature
ACAPI_AnalyticalModel_GetAnalyticalLoadCases  API 25 feature
ACAPI_AnalyticalModel_GetAnalyticalLoadCombination  API 25 feature
ACAPI_AnalyticalModel_GetAnalyticalLoadCombinations  API 25 feature
ACAPI_AnalyticalModel_GetAnalyticalLoadGroup  API 25 feature
ACAPI_AnalyticalModel_GetAnalyticalLoadGroups  API 25 feature
ACAPI_AnalyticalModel_GetAnalyticalMemberConnections  API 24 feature
ACAPI_AnalyticalModel_GetAnalyticalModel  API 24 feature
ACAPI_AnalyticalModel_GetAnalyticalModelVariation  API 24 feature
ACAPI_AnalyticalModel_GetVisibilitySettings  API 26 feature
ACAPI_AnalyticalModel_SetVisibilitySettings  API 26 feature
ACAPI_AnalyticalModel_GetAnalyticalPointLoadGeometry  API 25 feature
ACAPI_AnalyticalModel_GetAnalyticalRelease  API 24 feature
ACAPI_AnalyticalModel_GetAnalyticalSupportGeometry  API 24 feature
ACAPI_AnalyticalModel_GetAnalyticalSurfaceLoadGeometry  API 25 feature
ACAPI_AnalyticalModel_GetComplementaryProjectMemberType  API 24 feature
ACAPI_AnalyticalModel_GetCurrentAnalyticalModel  API 24 feature
ACAPI_AnalyticalModel_GetCurveElements  API 24 feature
ACAPI_AnalyticalModel_GetCurveMember  API 24 feature
ACAPI_AnalyticalModel_GetEdgeLoadFromElement  API 25 feature
ACAPI_AnalyticalModel_GetLCSOfAnalyticalMember  API 24 feature
ACAPI_AnalyticalModel_GetLCSOfAnalyticalMemberInIntersection  API 26 feature
ACAPI_AnalyticalModel_GetLinkFromElement  API 25 feature
ACAPI_AnalyticalModel_GetPointLoadFromElement  API 25 feature
ACAPI_AnalyticalModel_GetSupportFromElement  API 25 feature
ACAPI_AnalyticalModel_GetSurfaceElements  API 24 feature
ACAPI_AnalyticalModel_GetSurfaceLoadFromElement  API 25 feature
ACAPI_AnalyticalModel_GetSurfaceMember  API 24 feature
ACAPI_AnalyticalModel_SetAnalyticalRelease  API 24 feature
ACAPI_AnalyticalModel_SetElementFromEdgeLoad  API 25 feature
ACAPI_AnalyticalModel_SetElementFromLink  API 25 feature
ACAPI_AnalyticalModel_SetElementFromPointLoad  API 25 feature
ACAPI_AnalyticalModel_SetElementFromSupport  API 25 feature
ACAPI_AnalyticalModel_SetElementFromSurfaceLoad  API 25 feature
ACAPI_AnalyticalModel_UpdateAnalyticalModel  API 24 feature
ACAPI_AnalyticalModel_SetGenerationSettingsToNoRule  API 26 feature
 
ACAPI_Attribute_Create
ACAPI_Attribute_CreateExt
ACAPI_Attribute_Delete
ACAPI_Attribute_DeleteMore
ACAPI_Attribute_Get
ACAPI_Attribute_GetDef
ACAPI_Attribute_GetDefExt
ACAPI_Attribute_GetNum
ACAPI_Attribute_GetUserData
ACAPI_Attribute_Modify
ACAPI_Attribute_ModifyExt
ACAPI_Attribute_Search
ACAPI_Attribute_SetUserData
ACAPI_Attribute_GetClassificationItems  API 23 feature
ACAPI_Attribute_GetClassificationInSystem  API 23 feature
ACAPI_Attribute_AddClassificationItem  API 23 feature
ACAPI_Attribute_RemoveClassificationItem  API 23 feature
ACAPI_Attribute_IsClassificationItemVisible  API 23 feature
ACAPI_Attribute_GetFolder  API 26 feature
ACAPI_Attribute_CreateFolder  API 26 feature
ACAPI_Attribute_DeleteFolder  API 26 feature
ACAPI_Attribute_GetFolderContent  API 26 feature
ACAPI_Attribute_RenameFolder  API 26 feature
ACAPI_Attribute_GetFolderContent  API 26 feature
ACAPI_Interface_CreateAttributePicker  API 26 feature
ACAPI_Attribute_CreateAttributeFolderPicker  API 26 feature
ACAPI_Attribute_GetCurrentAttributeSetReader  API 26 feature
ACAPI_Attribute_Move  API 26 feature
ACAPI_Attribute_GetPropertyDefinitions  API 23 feature
ACAPI_Attribute_GetPropertyValue  API 23 feature
ACAPI_Attribute_GetPropertyValues  API 23 feature
ACAPI_Attribute_GetPropertyValuesByGuid  API 23 feature
ACAPI_Attribute_SetProperty  API 23 feature
ACAPI_Attribute_SetProperties  API 23 feature
ACAPI_Attribute_IsPropertyDefinitionValueEditable  API 23 feature
ACAPI_Attribute_IsPropertyDefinitionAvailable  API 23 feature
ACAPI_Attribute_IsPropertyDefinitionVisible  API 23 feature
ACAPI_AttributeList_AddProperty  API 23 feature
ACAPI_AttributeList_DeleteProperty  API 23 feature
ACAPI_AttributeList_ModifyPropertyValue  API 23 feature
ACAPI_Automate
 
ACAPI_Body_AddEdge
ACAPI_Body_AddPolygon
ACAPI_Body_AddPolyNormal
ACAPI_Body_AddVertex
ACAPI_Body_Create
ACAPI_Body_Dispose
ACAPI_Body_Finish
 
ACAPI_CallCommand
ACAPI_CallUndoableCommand
ACAPI_Classification_ChangeClassificationItem  API 21 feature
ACAPI_Classification_ChangeClassificationSystem  API 21 feature
ACAPI_Classification_CreateClassificationItem  API 21 feature
ACAPI_Classification_CreateClassificationSystem  API 21 feature
ACAPI_Classification_DeleteClassificationItem  API 21 feature
ACAPI_Classification_DeleteClassificationSystem  API 21 feature
ACAPI_Classification_GetClassificationItem  API 21 feature
ACAPI_Classification_GetClassificationItemChildren  API 21 feature
ACAPI_Classification_GetClassificationItemParent  API 21 feature
ACAPI_Classification_GetClassificationSystem  API 21 feature
ACAPI_Classification_GetClassificationSystemRootItems  API 21 feature
ACAPI_Classification_GetClassificationSystems  API 21 feature
ACAPI_Classification_Import  API 21 feature
ACAPI_Command_Call
ACAPI_Command_CallFromEventLoop  API 19 feature
ACAPI_Command_ExternalCall
ACAPI_Command_Test
 
ACAPI_Database
ACAPI_Database_GetLast3DDefLevels  API 26 feature
ACAPI_Database_SetLast3DDefLevels  API 26 feature
ACAPI_DisposeAddParHdl
ACAPI_DisposeAttrDefsHdls
ACAPI_DisposeAttrDefsHdlsExt
ACAPI_DisposeBeamRelationHdls
ACAPI_DisposeBeamSegmentRelationHdls  API 23 feature
ACAPI_DisposeElemMemoHdls
ACAPI_DisposeParagraphsHdl
ACAPI_DisposeRoomRelationHdls
ACAPI_DisposeWallRelationHdls
 
ACAPI_ElemComponent_GetPropertyDefinitions  API 25 feature
ACAPI_ElemComponent_GetPropertyValue  API 25 feature
ACAPI_ElemComponent_GetPropertyValues  API 25 feature
ACAPI_ElemComponent_GetPropertyValuesByGuid  API 25 feature
ACAPI_ElementGroup_Create
ACAPI_ElementGroup_GetAllGroupedElems
ACAPI_ElementGroup_GetGroup
ACAPI_ElementGroup_GetGroupedElems
ACAPI_ElementGroup_GetRootGroup
ACAPI_ElementGroup_GetUserData
ACAPI_ElementGroup_SetUserData
ACAPI_ElementSet_Create
ACAPI_ElementSet_Delete
ACAPI_ElementSet_GetData
ACAPI_ElementSet_Identify
ACAPI_Element_AddClassificationItem  API 21 feature
ACAPI_Element_AddClassificationItemDefault  API 21 feature
ACAPI_Element_AttachObserver
ACAPI_Element_Change
ACAPI_Element_ChangeDefaults
ACAPI_Element_ChangeDefaultsExt
ACAPI_Element_ChangeExt
ACAPI_Element_ChangeMemo
ACAPI_Element_ChangeMore
ACAPI_Element_ChangeParameters
ACAPI_Element_Create
ACAPI_Element_CreateExt
ACAPI_Element_Decompose
ACAPI_Element_Delete
ACAPI_Element_DeleteSelected  API 23 feature
ACAPI_Element_DeleteUserData
ACAPI_Element_DetachObserver
ACAPI_Element_DrwGuidToLinkId
ACAPI_Element_Edit
ACAPI_Element_Filter
ACAPI_Element_Get
ACAPI_Element_GetActualOverrideStyle  API 20 feature
ACAPI_Element_Get3DInfo
ACAPI_Element_GetClassificationInSystem  API 21 feature
ACAPI_Element_GetClassificationInSystemDefault  API 21 feature
ACAPI_Element_GetClassificationItems  API 21 feature
ACAPI_Element_GetClassificationItemsDefault  API 21 feature
ACAPI_Element_GetCollisions  API 21 feature
ACAPI_Element_GetComponents  API 25 feature
ACAPI_Element_GetComponents_Obsolete
ACAPI_Element_GetConnectedElements
ACAPI_Element_GetDefaults
ACAPI_Element_GetDefaultsExt
ACAPI_Element_GetDescriptors
ACAPI_Element_GetElemList
ACAPI_Element_GetElemListByIFCIdentifier  API 18 feature
ACAPI_Element_GetHeader
ACAPI_Element_GetHotspots  API 18 feature
ACAPI_Element_GetIFCAttributes
ACAPI_Element_GetIFCClassificationReferences
ACAPI_Element_GetIFCIdentifier  API 18 feature
ACAPI_Element_GetIFCProperties
ACAPI_Element_GetIFCPropertyValuePrimitiveType
ACAPI_Element_GetIFCType  API 19 feature
ACAPI_Element_GetLinkFlags
ACAPI_Element_GetLinkedPropertyObjects
ACAPI_Element_GetCategoryValue  API 19 feature
ACAPI_Element_GetCategoryValueDefault  API 19 feature
ACAPI_Element_GetLinks
ACAPI_Element_GetMemo
ACAPI_Element_Merge_Elements  API 18 feature
ACAPI_Element_Merge_GetMergedElements  API 18 feature
ACAPI_Element_Merge_Remove  API 18 feature
ACAPI_Element_GetObservedElements
ACAPI_Element_GetPropertyValues  API 22 feature
ACAPI_Element_GetPropertyValuesByGuid  API 22 feature
ACAPI_Element_GetPropertiesDefault  API 20 feature
ACAPI_Element_GetPropertyDefinitions  API 20 feature
ACAPI_Element_GetPropertyValuesOfDefaultElem  API 22 feature
ACAPI_Element_IsClassificationItemVisible  API 21 feature
ACAPI_Element_IsClassificationItemVisibleDefault  API 21 feature
ACAPI_Element_IsPropertyDefinitionAvailable  API 21 feature
ACAPI_Element_IsPropertyDefinitionAvailableDefault  API 21 feature
ACAPI_Element_IsPropertyDefinitionValueEditable  API 22 feature
ACAPI_Element_IsPropertyDefinitionValueEditableDefault  API 22 feature
ACAPI_Element_IsPropertyDefinitionVisible  API 21 feature
ACAPI_Element_IsPropertyDefinitionVisibleDefault  API 21 feature
ACAPI_ElementList_AddProperty  API 20 feature
ACAPI_ElementList_ModifyPropertyValue  API 20 feature
ACAPI_ElementList_DeleteProperty  API 20 feature
ACAPI_Element_GetElementsWithClassification  API 23 feature
ACAPI_Element_GetPropertyObjects
ACAPI_Element_GetQuantities
ACAPI_Element_GetMoreQuantities
ACAPI_Element_GetRelations
ACAPI_Element_GetSurfaceQuantities API 20 feature
ACAPI_Element_GetSyTran
ACAPI_Element_GetUserData
ACAPI_Element_GetVisualOverriddenImage API 20 feature
ACAPI_Element_GuidToUnId
ACAPI_Element_Link
ACAPI_Element_LinkIdToDrwGuid
ACAPI_Element_RemoveClassificationItem  API 21 feature
ACAPI_Element_RemoveClassificationItemDefault  API 21 feature
ACAPI_Element_RemoveIFCClassificationReference
ACAPI_Element_RemoveIFCProperty
ACAPI_Element_Select
ACAPI_Element_DeselectAll  API 23 feature
ACAPI_Element_SetCategoryValue  API 19 feature
ACAPI_Element_SetCategoryValueDefault  API 19 feature
ACAPI_Element_SetIFCAttribute
ACAPI_Element_SetIFCClassificationReference
ACAPI_Element_SetIFCProperty
ACAPI_Element_SetLinkedPropertyObjects
ACAPI_Element_SetProperties  API 20 feature
ACAPI_Element_SetPropertiesOfDefaultElem  API 22 feature
ACAPI_Element_SetProperty  API 22 feature
ACAPI_Element_SetUserData
ACAPI_Element_ShapePrims
ACAPI_Element_ShapePrimsExt
ACAPI_Element_SolidLink_Create
ACAPI_Element_SolidLink_GetFlags
ACAPI_Element_SolidLink_GetOperation
ACAPI_Element_SolidLink_GetOperators
ACAPI_Element_SolidLink_GetTargets
ACAPI_Element_SolidLink_GetTime
ACAPI_Element_SolidLink_Remove
ACAPI_Element_SolidOperation_Create  API 20 feature
ACAPI_Element_Tool
ACAPI_Element_Trim_Elements
ACAPI_Element_Trim_ElementsWith
ACAPI_Element_Trim_Remove
ACAPI_Element_Trim_GetTrimType
ACAPI_Element_Trim_GetTrimmedElements
ACAPI_Element_Trim_GetTrimmingElements
ACAPI_Element_UnIdToGuid
ACAPI_Element_Unlink
ACAPI_Element_GrantElements  API 23 feature
ACAPI_Element_GetNoteAutotexts  API 26 feature
ACAPI_Element_GetNoteKeywordForAutotextID  API 26 feature

ACAPI_ElemDifferenceGenerator_GetState  API 22 feature
ACAPI_ElemDifferenceGenerator_GenerateDifference  API 22 feature
ACAPI_Environment
 
ACAPI_Favorite_Create
ACAPI_Favorite_Change  API 23 feature
ACAPI_Favorite_Rename  API 23 feature
ACAPI_Favorite_Delete
ACAPI_Favorite_Export  API 20 feature
ACAPI_Favorite_Get
ACAPI_Favorite_GetNum
ACAPI_Favorite_GetPreviewImage  API 23 feature
ACAPI_Favorite_Import  API 20 feature
ACAPI_Favorite_Read  API 20 feature
 
ACAPI_FreeCWContourPtr
ACAPI_FreeGDLModelViewOptionsPtr
 
ACAPI_GetExtensionInstance
ACAPI_GetMainWindow
ACAPI_GetOwnLocation
ACAPI_GetOwnResModule
ACAPI_GetPreferences
ACAPI_GetPreferences_Platform
ACAPI_GetReleaseNumber
ACAPI_GetToken  API 26 feature
ACAPI_Goodies
ACAPI_Goodies_ElemTypeToNeigID  API 26 feature
ACAPI_Goodies_GetElemTypeName  API 26 feature
ACAPI_Goodies_GetMarkerParent  API 26 feature
ACAPI_Goodies_NeigIDToElemType  API 26 feature
 
ACAPI_IFC_APIGuidToIFCGuid API 26 feature
ACAPI_IFC_ComplementIFCDifferenceAndMergeIFCRelationshipData API 26 feature
ACAPI_IFC_GetIFCDifference API 26 feature
ACAPI_IFC_GetIFCDifferenceState API 26 feature
ACAPI_IFC_GetIFCExportTranslatorsList API 26 feature
ACAPI_IFC_GetIFCRelationshipData API 26 feature
ACAPI_IFC_IFCGuidToAPIGuid API 26 feature
ACAPI_IFC_InvokeIFCDifferenceExportSettingsDlg API 26 feature
 
ACAPI_Inform_AdditionalFileWasCreated API 24 feature
 
ACAPI_Install_AttrManagerImportMethod  API 26 feature
ACAPI_Install_ElemSetSaveOldFormatHandler  API 20 feature
ACAPI_Install_ESYMHandler
ACAPI_Install_FileTypeHandler
ACAPI_Install_FileTypeHandler3D
ACAPI_Install_MenuHandler
ACAPI_Install_ModulCommandHandler
ACAPI_Install_ModulDataMergeHandler
ACAPI_Install_ModulDataSaveOldFormatHandler
ACAPI_Install_NavigatorAddOnViewPointDataConvertNewFormatHandler  API 22 feature
ACAPI_Install_NavigatorAddOnViewPointDataMergeHandler  API 22 feature
ACAPI_Install_NavigatorAddOnViewPointDataSaveOldFormatHandler  API 22 feature
ACAPI_Install_PanelHandler
ACAPI_Install_PropertyObjectHandler
ACAPI_Install_SettingsHandler  API 20 feature
ACAPI_Install_ClassificationVisibilityHandler  API 21 feature
ACAPI_Install_PropertyVisibilityHandler  API 21 feature
ACAPI_Install_PublisherSaveOption   API 22 feature
ACAPI_Install_PublisherSaveMethod   API 22 feature
ACAPI_Install_PublisherTranslatorGetter   API 26 feature
ACAPI_Install_PublisherDefaultTranslatorGetter   API 26 feature
ACAPI_Install_AddOnCommandHandler   API 25 feature
 
ACAPI_Interface
ACAPI_Interface_ClearElementHighlight API 26 feature
ACAPI_Interface_InvokeForwardDialog API 26 feature
ACAPI_Interface_SetElementHighlight API 26 feature
 
ACAPI_KeepInMemory
 
ACAPI_LibPart_AddSection
ACAPI_LibPart_Create
ACAPI_LibPart_EndSection
ACAPI_LibPart_Get
ACAPI_LibPart_GetDetails
ACAPI_LibPart_GetHotspots
ACAPI_LibPart_GetNum
ACAPI_LibPart_GetParams
ACAPI_LibPart_GetSect_2DDrawHdl
ACAPI_LibPart_GetSect_ParamDef
ACAPI_LibPart_GetSection
ACAPI_LibPart_GetSectionList
ACAPI_LibPart_NewSection
ACAPI_LibPart_PatternSearch
ACAPI_LibPart_Register
ACAPI_LibPart_RegisterAll
ACAPI_LibPart_Save
ACAPI_LibPart_Search
ACAPI_LibPart_SetDetails_ParamDef
ACAPI_LibPart_SetUpSect_2DDrawHdl
ACAPI_LibPart_ShapePrims
ACAPI_LibPart_UpdateSection
ACAPI_LibPart_WriteSection
ACAPI_ListData_Get
ACAPI_ListData_GetLocal
ACAPI_ListData_GetNum
ACAPI_ListData_GetSet
ACAPI_ListData_GetSetNum
ACAPI_ListData_Search
 
ACAPI_MarkUp_AddComment  API 21 feature
ACAPI_MarkUp_AttachElements  API 21 feature
ACAPI_MarkUp_Create  API 21 feature
ACAPI_MarkUp_Change  API 21 feature
ACAPI_MarkUp_Delete  API 21 feature
ACAPI_MarkUp_DetachElements  API 21 feature
ACAPI_MarkUp_ExportToBCF  API 23 feature
ACAPI_MarkUp_GetAttachedElements  API 21 feature
ACAPI_MarkUp_GetComments  API 21 feature
ACAPI_MarkUp_GetList  API 21 feature
ACAPI_MarkUp_ImportFromBCF  API 23 feature
 
ACAPI_ModulData_Delete
ACAPI_ModulData_Get
ACAPI_ModulData_GetInfo
ACAPI_ModulData_GetList
ACAPI_ModulData_Store
 
ACAPI_Navigator  API 22 feature
 
ACAPI_Notify_AttributeReplacement API 25 feature
ACAPI_Notify_CatchChangeDefaults
ACAPI_Notify_CatchNewElement
ACAPI_Notify_CatchProjectEvent
ACAPI_Notify_CatchSelectionChange
ACAPI_Notify_CatchToolChange
ACAPI_Notify_CatchViewEvent
ACAPI_Notify_GetParentElement
ACAPI_Notify_GetTranParams
ACAPI_Notify_InstallElementObserver
ACAPI_Notify_ClassificationVisibilityChanged  API 21 feature
ACAPI_Notify_PropertyVisibilityChanged  API 21 feature
ACAPI_Notify_RegisterEventHandler  Featuring API 26
ACAPI_Notify_UnregisterEventHandler  Featuring API 26
 
ACAPI_Override_ChangeOverrideCombination  API 20 feature
ACAPI_Override_ChangeOverrideRule  API 20 feature
ACAPI_Override_CreateOverrideCombination  API 20 feature
ACAPI_Override_CreateOverrideRule  API 20 feature
ACAPI_Override_DeleteOverrideCombination  API 20 feature
ACAPI_Override_DeleteOverrideRule  API 20 feature
ACAPI_Override_GetOverrideCombination  API 20 feature
ACAPI_Override_GetOverrideCombinationList  API 20 feature
ACAPI_Override_GetOverrideRule  API 20 feature
ACAPI_Override_GetOverrideCombinationList  API 20 feature
 
ACAPI_Property_ChangePropertyDefinition  API 20 feature
ACAPI_Property_ChangePropertyGroup  API 20 feature
ACAPI_Property_CreatePropertyDefinition  API 20 feature
ACAPI_Property_CreatePropertyGroup  API 20 feature
ACAPI_Property_DeletePropertyDefinition  API 20 feature
ACAPI_Property_DeletePropertyGroup  API 20 feature
ACAPI_Property_GetPropertyDefinition  API 20 feature
ACAPI_Property_GetPropertyDefinitions  API 20 feature
ACAPI_Property_GetPropertyGroup  API 20 feature
ACAPI_Property_GetPropertyGroups  API 20 feature
ACAPI_Property_Import  API 21 feature
ACAPI_Property_IsValidValue  API 25 feature
ACAPI_Property_SetPropertyValueFromString  API 25 feature
ACAPI_Property_GetPropertyValueString  API 25 feature
 
ACAPI_Protection_GetProtectionMode  API 26 feature
ACAPI_Protection_GetSerialNumber  API 26 feature
ACAPI_Protection_GetBoxMask  API 26 feature
ACAPI_Protection_GetConfigurationNumber  API 26 feature
ACAPI_Protection_GetNumberOfLicenses  API 26 feature
ACAPI_Protection_GetExpirationTime  API 26 feature
ACAPI_Protection_GetPartnerId  API 26 feature
ACAPI_Protection_IsSSALevelAtLeast  API 26 feature
 
ACAPI_RegisterModelessWindow
ACAPI_Register_AttributeImportFormat  API 26 feature
ACAPI_Register_AttributePanel
ACAPI_Register_BuiltInLibrary
ACAPI_Register_ESYM
ACAPI_Register_FileType
ACAPI_Register_InfoBoxPanel
ACAPI_Register_Menu
ACAPI_Register_ModulDataHandler
ACAPI_Register_NavigatorAddOnViewPointDataHandler  API 22 feature
ACAPI_Register_PropertyObjectHandler
ACAPI_Register_RequiredService
ACAPI_Register_SettingsPanel
ACAPI_Register_Subtype
ACAPI_Register_SupportedService
ACAPI_Register_SettingsObserver  API 20 feature
ACAPI_Register_ClassificationVisibilityHandler  API 21 feature
ACAPI_Register_PropertyVisibilityHandler  API 21 feature
ACAPI_Register_PublishFormat API 23 feature
ACAPI_Resource_GetFixStr
ACAPI_Resource_GetLocStr
ACAPI_Resource_GetLocUStr
 
ACAPI_Selection_Get
ACAPI_Selection_SetMarquee
ACAPI_SetDllTermHookProc
ACAPI_SetPreferences
ACAPI_SetPreferences_OldVersion
 
ACAPI_TeamworkControl_HasConnection
ACAPI_TeamworkControl_IsOnline
ACAPI_TeamworkControl_IsServerLibPart
ACAPI_TeamworkControl_HasCreateRight
ACAPI_TeamworkControl_HasDeleteModifyRight
ACAPI_TeamworkControl_GetLockableStatus
ACAPI_TeamworkControl_FindLockableObjectSet
ACAPI_TeamworkControl_ReserveLockable
ACAPI_TeamworkControl_ReleaseLockable
ACAPI_TeamworkControl_ReserveElements
ACAPI_TeamworkControl_ReleaseElements
ACAPI_TeamworkControl_ReserveHotlinkCacheManagement
ACAPI_TeamworkControl_ReleaseHotlinkCacheManagement
ACAPI_TeamworkControl_GetHotlinkCacheManagementOwner
ACAPI_TeamworkControl_GetUsernameFromId API 25 feature
ACAPI_TeamworkControl_SendChanges API 25 feature
ACAPI_TeamworkControl_ReceiveChanges API 25 feature
ACAPI_TeamworkControl_GetTeamworkProjectDetails API 25 feature
 
ACAPI_UnregisterModelessWindow
 
ACAPI_WriteReport
 
APIAny_ActivateSessionReportID  API 26 feature
APIAny_AddMDCLParameterID
APIAny_CalcCoreOffsetToSideOffsetID
APIAny_CalcSideOffsetToCoreOffsetID
APIAny_CalcSunOnPlaceID
APIAny_ChangeAParameterID
APIAny_ChangeAutoTextFlagID
APIAny_ChangeContentID
APIAny_ChangeMDCLParameterID
APIAny_CheckLibPartSubtypeOfID
APIAny_CloseParametersID
APIAny_CompareLibPartUnIdsID
APIAny_ConvertMimePictureID
APIAny_ConvertPictureID
APIAny_DeletePolyNodeID
APIAny_DeleteSubPolyID
APIAny_Elem2UIPriorityID
APIAny_ElemTypeToNeigID
APIAny_EnableRenovationOverrideID
APIAny_EnableVisualOverrideID
APIAny_FreeMDCLParameterListID
APIAny_GetActParametersID
APIAny_GetAutoTextFlagID
APIAny_GetAutoTextKeysID
APIAny_GetAutoTextsID
APIAny_GetBuiltInLibpartUnIdID
APIAny_GetElemCreatorToolUnIdID
APIAny_GetElemCreatorToolUnIdID
APIAny_GetElemLibPartUnIdID
APIAny_GetLibPartToolVariationID
APIAny_GetMDCLParameterID
APIAny_GetMDCLParameterNumID
APIAny_GetMainGroupGuidID
APIAny_GetMarkerParentID
APIAny_GetOpeningTransformationID
APIAny_GetParamValuesID
APIAny_GetRenovationFilterNameID
APIAny_GetRenovationStatusNameID
APIAny_GetRoomImageID  API 23 feature
APIAny_GetSelectedElementID
APIAny_GetSkylightHolePolygonID
APIAny_GetSplineMaxDistID
APIAny_GetTextLineLengthID
APIAny_GetTextSizeFactorID
APIAny_GetTextureCoordID
APIAny_GetUnloadedLibpartNameID
APIAny_InitMDCLParameterListID
APIAny_InsertPolyNodeID
APIAny_InsertSubPolyID
APIAny_NeigIDToElemTypeID
APIAny_NeigToCoordID
APIAny_OpenParametersID
APIAny_SearchElementByCoordID
APIAny_SetAnAutoTextID
APIAny_SetEmptyHoleUnIdID
APIAny_SetSelectedElementNeigID
APIAny_TriangulatePolyID
APIAny_UI2ElemPriorityID
APIAny_UsableGDLStringID
APIAny_SetMasterLayoutOnLayoutID  API 18 feature
APIAny_ElemHasVisibleSkinID  API 18 feature
 
APIAttributeReplacementHandlerProc API 25 feature
APICustomWindowHandlerProc
 
APIDb_AddTextWindowContentID
APIDb_CalcBoundsID
APIDb_BuildWindowValidatorID  API 22 feature
APIDb_ChangeCurrentDatabaseID
APIDb_ChangeDrawingScaleID
APIDb_ChangeGridSettingsID
APIDb_CheckDrawingStatusID
APIDb_CheckWindowValidatorID  API 22 feature
APIDb_CloseWindowID
APIDb_CoordToPointID
APIDb_CreateSubSetID
APIDb_CreationOrderGetNextID
APIDb_DeleteDatabaseID
APIDb_DestroyWindowValidatorID  API 22 feature
APIDb_DisposeCreationOrderTableID
APIDb_DoClipID
APIDb_DrawElementID
APIDb_DrawOrderGetNextID
APIDb_DrawOrderInitID
APIDb_DrawOrderTermID
APIDb_DrawStoryControlID
APIDb_GetActualRenovationFilterID
APIDb_GetCurrentDatabaseID
APIDb_GetDBUnIdFromGuidID  API 18 feature
APIDb_GetGuidFromDBUnIdID  API 18 feature
APIDb_GetCurrentWindowID
APIDb_GetDatabaseInfoID
APIDb_GetDetailDatabasesID
APIDb_GetDocumentFrom3DDatabasesID
APIDb_GetDrawingLinkID
APIDb_GetDrawingScaleID
APIDb_GetElementURLRefID
APIDb_GetElevationDatabasesID
APIDb_GetExtent3DID
APIDb_GetExtentID
APIDb_GetFullDrawingContentBoxID
APIDb_GetGridSettingsID
APIDb_GetHotlinkNodeTreeID
APIDb_GetHotlinkNodesID
APIDb_GetHotlinkInstancesID
APIDb_GetCompoundInfoStringID
APIDb_GetElementInfoStringID
APIDb_GetHotLinkOwnerID
APIDb_GetHotlinkRootNodeGuidID
APIDb_GetHotlinkProxyElementTableID  API 25 feature
APIDb_GetInteriorElevationDatabasesID
APIDb_GetLayoutBookID  API 18 feature
APIDb_GetLayoutDatabasesID
APIDb_GetLast3DDefLevelsID
APIDb_GetLocOrigoID
APIDb_GetMasterLayoutDatabasesID
APIDb_GetOffsetID
APIDb_GetOwnWindowsID
 
APIDb_GetRVMChangeCustomSchemeID  API 18 feature
APIDb_GetRVMChangeFirstIssueID  API 18 feature
APIDb_GetRVMChangesFromChangeIdsID  API 18 feature
APIDb_GetRVMChangesID  API 18 feature
APIDb_GetRVMDocumentRevisionChangesID  API 18 feature
APIDb_GetRVMDocumentRevisionsID  API 18 feature
APIDb_GetRVMElemChangeIdsID  API 18 feature
APIDb_GetRVMIssueCustomSchemeID  API 18 feature
APIDb_GetRVMIssueDocumentRevisionsID  API 18 feature
APIDb_GetRVMIssuesID  API 18 feature
APIDb_GetRVMLayoutCurrentRevisionChangesID  API 18 feature
 
APIDb_GetSectionDatabasesID
APIDb_GetSubSetDefaultID
APIDb_GetSubSetID
APIDb_GetTWOwnerID
APIDb_GetWorksheetDatabasesID
APIDb_GetZoomID
APIDb_GetRenovationFiltersID  API 18 feature
APIDb_GetElementCategoriesID  API 19 feature
APIDb_GetElementCategoryValuesID  API 19 feature
APIDb_InitCreationOrderTableID
APIDb_ModifyDatabaseID
APIDb_NewDatabaseID
APIDb_NewWindowID
APIDb_PointToCoordID
APIDb_ReSetZoomID
APIDb_RebuildCurrentDatabaseID
APIDb_RebuildWindowValidatorID  API 22 feature
APIDb_RedrawCurrentDatabaseID
APIDb_RefreshElementID
APIDb_ResetCurrentDatabaseID
APIDb_ResetCurrentWindowID
APIDb_RoomReductionsID
APIDb_SetActualRenovationFilterID  API 25 feature
APIDb_SetElementURLRefID
APIDb_SetLast3DDefLevelsID
APIDb_SetZoomID
APIDb_SetWindowIdID
APIDb_StartClippingSessionID
APIDb_StartDrawingDataID
APIDb_StopClippingSessionID
APIDb_StopDrawingDataID
APIDb_StoreViewSettingsID
APIDb_Switch3DSightID
 
APIDefaultsChangeHandlerProc
 
APIDllTermHookProc
 
APIDo_ChangeWindowID
APIDo_CloseID
APIDo_GoToViewID
APIDo_LoadLibrariesID
APIDo_ReloadLibrariesID  API 21 feature
APIDo_NewProjectID
APIDo_OpenID
APIDo_PhotoRenderID
APIDo_PrintID
APIDo_PublishID
APIDo_QuitID
APIDo_RebuildID
APIDo_RedrawID
APIDo_SaveAsModuleFileID
APIDo_SaveID
APIDo_ShowAllIn3DID
APIDo_ShowSelectionIn3DID
APIDo_ZoomID
APIDo_ZoomToElementsID  API 21 feature
APIDo_ZoomToSelectedID
APIDo_EditHierarchicalElemID
APIDo_OkHierarchicalElemID
APIDo_CancelHierarchicalElemID
 
APIElementEventHandlerProc
 
APIEnv_AddLibrariesID
APIEnv_ApplicationID
APIEnv_CanChangePlaceSetsID
APIEnv_Change3DCuttingPlanesID
APIEnv_Change3DImageSetsID
APIEnv_Change3DProjectionSetsID
APIEnv_Change3DStyleID  API 21 feature
APIEnv_Change3DWindowSetsID
APIEnv_ChangeAutoIntersectID
APIEnv_ChangeDocumentFrom3DDefaultsID
APIEnv_ChangeDocumentFrom3DSettingsID
APIEnv_ChangeCurrLayerCombID
APIEnv_ChangeGDLDateID
APIEnv_ChangeGhostRecordID
APIEnv_ChangeLayoutSetsID
APIEnv_ChangeMarkerDrawingEnabledID
APIEnv_ChangePlaceSetsID
APIEnv_ChangeProjectNotesID
APIEnv_ChangeRenderingSetsID
APIEnv_ChangeShowHideStateID
APIEnv_ChangeStorySettingsID
APIEnv_ChangeStructureDisplayID
APIEnv_ChangeSunSetsID
APIEnv_ChangeViewOptionsID
APIEnv_CheckLibrariesID
APIEnv_CopyFilesIntoLibraryID
APIEnv_Create3DStyleID  API 21 feature
APIEnv_CreateCopyOfGdlUserGlobalsHandleID  API 19 feature
APIEnv_CreateFolderInLibraryID
APIEnv_DeleteEmbeddedLibItemID  API 21 feature
APIEnv_DeleteEmbeddedLibItemsID  API 21 feature
APIEnv_DeleteGhostRecordID
APIEnv_DeleteGhostRecordID
APIEnv_DestroyCopyOfGdlUserGlobalsHandleID  API 19 feature
APIEnv_Get3DCuttingPlanesID
APIEnv_Get3DImageSetsID
APIEnv_Get3DProjectionSetsID
APIEnv_Get3DStyleID  API 21 feature
APIEnv_Get3DStyleListID  API 21 feature
APIEnv_Get3DWindowSetsID
APIEnv_GetConvertedUnitValueID
APIEnv_GetCurrLayerCombID
APIEnv_GetCurrPenSetID
APIEnv_GetDocumentFrom3DDefaultsID
APIEnv_GetDocumentFrom3DSettingsID
APIEnv_GetGDLDateID
APIEnv_GetGeoLocationID  API 25 feature
APIEnv_GetGhostRecordID
APIEnv_GetGhostStorySettingsID
APIEnv_GetLayoutSetsID
APIEnv_GetLibPartLockStatusID
APIEnv_GetLibPartRefGuidID
APIEnv_GetLibPartUnIDStrID
APIEnv_GetLibrariesID
APIEnv_GetMagicWandSetsID
APIEnv_GetExportToleranceID
APIEnv_GetMiscAppInfoID
APIEnv_GetMiscPlotterInfoID
APIEnv_GetMiscPrinterInfoID
APIEnv_GetNumberingGridLinesID
APIEnv_GetPlaceSetsID
APIEnv_GetPreferencesID
APIEnv_GetPrinterParsID
APIEnv_GetProjectNotesID
APIEnv_GetRenderingSceneNamesID
APIEnv_GetRenderingSetsID
APIEnv_GetShowHideStateID
APIEnv_GetSpecFolderID
APIEnv_GetStorySettingsID
APIEnv_GetStructureDisplayID
APIEnv_GetSunSetsID
APIEnv_GetSurveyPointTransformationID  API 25 feature
APIEnv_GetToolBoxInfoID
APIEnv_GetToolBoxModeID
APIEnv_GetTWAccessRightID
APIEnv_GetViewOptionsID
APIEnv_IsAutoGroupOnID
APIEnv_IsAutoIntersectOnID
APIEnv_IsInCurtainWallEditModeID
APIEnv_IsInStairEditModeID
APIEnv_IsInBeamEditModeID
APIEnv_IsInColumnEditModeID
APIEnv_IsMarkerDrawingEnabledID
APIEnv_IsSurveyPointLockedID  API 25 feature
APIEnv_IsSurveyPointVisibleID  API 25 feature
APIEnv_IsSuspendGroupOnID
APIEnv_NewLibDialID
APIEnv_OverwriteLibPartID
APIEnv_ProjectID
APIEnv_ProjectSharingID
APIEnv_ResetLibrariesID
APIEnv_SetCurrent3DStyleID  API 21 feature
APIEnv_SetCurrentRenderingSceneID
APIEnv_SetGeoLocationID  API 25 feature
APIEnv_SetLibrariesID
APIEnv_SetSurveyPointLockedID  API 25 feature
APIEnv_SetSurveyPointVisibilityID  API 25 feature
APIEnv_SetToolBoxModeID
 
APIESYMCommandProc
 
APIExternalCallBackProc
 
APIIFCRelationshipDataProc
 
APIIO3DCommandProc
APIIOCommandProc
 
APIIo_AddMenuItemTextID
APIIo_CancelUserInputID
APIIo_ClearNeigFilterID
APIIo_CloseProcessWindowID
APIIo_CompleteUserInputID
APIIo_DrawRubberArcID
APIIo_DrawRubberLineID
APIIo_GetArcID
APIIo_GetLastValidEmbeddedLPNameID
APIIo_GetLineID
APIIo_GetMenuItemFlagsID
APIIo_GetMenuItemTextID
APIIo_GetPointID
APIIo_GetPolyID
APIIo_GetProcessOnOffSwitchID
APIIo_HighlightElementsID
APIIo_IncProcessValueID
APIIo_InitNeigFilterID
APIIo_InitProcessWindowID
APIIo_Is3DCutawayEnabledID  API 20 feature
APIIo_IsCuttingPlanesVisibleID  API 20 feature
APIIo_IsProcessCanceledID
APIIo_ObjectSettingsID
APIIo_OpenLibPartFileDialogID
APIIo_OpenOtherObjectDialogID
APIIo_OpenPictureDialogID
APIIo_PetPaletteID
APIIo_ResetConstraintID
APIIo_SaveLibPartFileDialogID
APIIo_Set3DCutawayStatusID  API 20 feature
APIIo_SetConstraintID
APIIo_SetCuttingPlanesVisibilityID  API 20 feature
APIIo_SetMenuItemFlagsID
APIIo_SetMenuItemTextID
APIIo_SetNeigFilterID
APIIo_SetNextProcessPhaseID
APIIo_SetProcessOnOffSwitchID
APIIo_SetProcessValueID
APIIo_SetUserControlCallbackID
APIIo_SettingsDialogID
 
APILockChangeHandlerProc
 
APIMenuCommandProc
APIModulCommandProc
APIModulDataMergeHandlerProc
APIModulDataSaveOldFormatHandlerProc
 
APINavigatorAddOnViewPointDataConvertNewFormatHandlerProc  API 22 feature
APINavigatorAddOnViewPointDataMergeHandlerProc  API 22 feature
APINavigatorAddOnViewPointDataSaveOldFormatHandlerProc  API 22 feature
 
APINavigator_ChangeNavigatorItemID
APINavigator_ChangeNavigatorViewID
APINavigator_ChangeNavigatorVPItemID  API 22 feature
APINavigator_CreateNavigatorVPItemID  API 22 feature
APINavigator_DeleteNavigatorViewID
APINavigator_DeleteNavigatorVPItemID  API 22 feature
APINavigator_GetNavigatorChildNumID
APINavigator_GetNavigatorChildrenItemsID
APINavigator_GetNavigatorItemID
APINavigator_GetNavigatorParentItemID
APINavigator_GetNavigatorSetID
APINavigator_GetNavigatorSetNumID
APINavigator_GetNavigatorViewID
APINavigator_GetNavigatorVPItemChildrenID  API 22 feature
APINavigator_GetNavigatorVPItemID  API 22 feature
APINavigator_GetNavigatorVPRootGroupsID  API 22 feature
APINavigator_NewNavigatorViewID
APINavigator_SearchNavigatorItemID
APINavigator_RegisterCallbackInterfaceID  API 22 feature
APINavigator_SetNavigatorItemPositionID
 
APINumberingGridLineProc
 
APIPaletteControlCallBackProc
APIPanelCreateProc
APIPanelDestroyProc
APIPetPaletteCallBackProc
APIProjectEventHandlerProc
APIPropertyObjectCommandProc
 
APIReservationChangeHandlerProc
 
APISelectionChangeHandlerProc
 
APISettingsCreateProc  API 20 feature
APISettingsDestroyProc  API 20 feature
 
APIToolChangeHandlerProc
 
APIViewEventHandlerProc
 
AddPolyNodeProc
CheckEnvironment
DelPolyNodeProc
FreeData
Initialize
RegisterInterface
RoomReductionPolyProc
Get3DComponentProc
RubberLineInfoProc
ShapePrimsProc