API_​3DCutPlanesInfo

Data of the “3D Cutting Planes…” dialog.

    typedef struct {
        bool                   isCutPlanes;
        bool                   useCustom;
        short                  customPen;
        API_AttributeIndex     customMater;
        short                  nShapes;
        API_3DCutShapeType     **shapes;
        Int32                  filler_2[9];
    } API_3DCutPlanesInfo;

 

Members

isCutPlanes
3D cutaway on
useCustom
Custom edges and surfaces of elements cut in 3D Sections
customPen
Custom pen
customMater
Custom material
nShapes
Number of the shapes
shapes
Shapes of the cutting planes

 

Remarks

The API_3DCutPlanesInfo structure is used by the APIEnv_Get3DCuttingPlanesID and the APIEnv_Change3DCuttingPlanesID environment function.

Don’t forget to dispose the shapes handle when it is not needed any more.

 

Requirements

Version: API 3.1 or later
Header: APIdefs_Environment.h

 

See Also

API_3DCutShapeType
API_AttributeIndex
APIEnv_Get3DCuttingPlanesID
APIEnv_Change3DCuttingPlanesID
API Types