API_​3DCutShapeType

Shape of the 3D cutting plane.

    typedef struct {
        short                cutStatus;
        short                cutPen;
        API_AttributeIndex   cutMater;
        short                filler_1;
        double               pa;
        double               pb;
        double               pc;
        double               pd;
        double               filler_2[5];
    } API_3DCutShapeType;

 

Members

cutStatus
Reserved for internal use
cutPen
Pen of the cutplane
cutMater
Material of the cutplane
pa
Horizontal coordinate of the begin of the section line
pb
Vertical coordinate of the begin of the section line
pc
Horizontal coordinate of the end of the section line
pd
Vertical coordinate of the end of the section line

 

Remarks

This structure is a member of API_3DCutPlanesInfo.

 

Requirements

Version: API 3.1 or later
Header: APIdefs_Environment.h

 

See Also

API_3DCutPlanesInfo
API_AttributeIndex
APIEnv_Get3DCuttingPlanesID
APIEnv_Change3DCuttingPlanesID
API Types