API_​3DFilterAndCutSettings

Parameters of the ‘Filter and Cut Elements in 3D’ dialog.

    typedef struct {
        short                            firstStory3D;
        short                            lastStory3D;
        bool                             allStories;
        API_MarqueeFilter                marqueeFilter;
        bool                             trimToStoryRange;
        API_3DFilterModeID               filterMode;
        std::map<API_ElemTypeID, bool>   elemTypeFilter;
    } API_3DFilterAndCutSettings;

 

Members

firstStory3D
First story to convert. Valid only if allStories is false
lastStory3D
Last story to convert. Valid only if allStories is false
allStories
Create a 3D projection of all stories rather than a range of stories defined by firstStory3D..lastStory3D
marqueeFilter 26
Image only the elements that are within or outside the marquee area defined in the floor plan
trimToStoryRange 11
Trims elements to the story range (see the Trim Elements to story range checkbox in the Filter and Cut Elements in 3D dialog.
filterMode 20
The 3D filter mode. For available modes see API_3DFilterModeID enumeration. (output only)
elemTypeFilter 26
A map containig API_ElemTypeID-bool pairs. APIEnv_Change3DImageSetsID function will set element types with false value invisible on 3D and element types with true value visible. API_ZombieElemID will change the visibility of all element types regardless of other passed element types.

 

Remarks

This structure is used to retrieve and modify the data of the 3D image item settings by the APIEnv_Get3DImageSetsID and APIEnv_Change3DImageSetsID environment functions. Note that the visibility of GDL-based elements can also be modified through GDL parmeters which can overwrite the visibility settings in API_3DFilterAndCutSettings.

 

Requirements

Version: API 26 or later
Header: APIdefs_Environment.h

 

See Also

API Types, API_MarqueeFilter, APIEnv_Get3DImageSetsID, APIEnv_Change3DImageSetsID